why comcast can suck it, part clvii

For the past three years (possibly more, I don’t know), I’ve been paying my Comcast bill online. I’m all eco-friendly and shit when it comes to making sure I have my cable TV and internet service at home. Also, I hate mail unless it’s a check coming for me or a handwritten letter or a package, so I try to avoid it as much as possible. 

I got my regular monthly bill and I decided to go online and pay it today. Makes sense, right? It asks me to use my login address, which is also my email address. So, I did that. I used the same email address that my Comcast bill has been coming to for YEARS. And then I got this error message:

Missing or Invalid Information
Please correct the fields below outlined in red.
UserName Not Found 
I figure whatever. Comcast sucks and they probably accidentally deleted all of their accounts or something equally as stupid. So, I try to create a new account. It asks for an account number. You know where your account number can be found? On the bill you get in the mail. Know what I haven’t had in my hands since at least two apartments ago? (See above if you’re slow to catch on.)

Of course their website doesn’t work with Google Chrome, so I’m attempting to use their awesome online chat feature. I’m currently 14* in the queue. If you never hear from me again, it’s because I’ve went to the Comcast billing office and went all Tiger Woods’ wife crazy on that big ass glass building. 

*As I was typing this, I got bumped to number 15 in the queue. How does someone cut in front of you in a virtual line? 

Posted via web from twodolla’s posterous.

2 Comments

  1. ComcastMark

    I am sorry for the trouble. Is the email address that you used the primary address? Did you try to log in with your primary user ID? If you can send me the phone number on the account, I will be happy to look into this for you.

    Thanks in advance,

    Mark Casem
    Comcast Customer Connect
    National Customer Operations
    We_Can_Help@cable.comcast.com

  2. willis

    they changed their billing system a few months ago – the same thing happened to me. it’s now linked to the primary email address on your account.

    their online CS people fucking suck, incidentally. you’re better off calling 651-222-3333. they’re actually in MN versus some shitty overseas center which I’m pretty sure the online people are from.

What's up?